147 side lights blowing - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-10-09 Thread Starter
Status: -
Join Date: Oct 2009
Location: United Kingdom
County: Glasgow
Posts: 1

Member car:

147 2.0 tspark

147 side lights blowing

My Alfa 147 (2003 model) has recently blown the two front side lights and the offside brake light. The garage replaced the front lights but they still didnt work. The fuse is Ok as well. I understand there have been a number of 147s with a similar fault. Does anybody know what might be wrong?
London Johnnie is offline  
Sponsored Links
Status: -
AO Member
Join Date: Mar 2008
Location: United Kingdom
County: Fife
Posts: 88
hi, i had/have a similar fault on my 03 147, the offside front side light kept blowing...turned out to be the body computer, luckily it was under manufacturers warranty but i think it came in at about 450. I have just returned from a tour overseas to find the same problem. I thought as a new computer had been fitted it may have just been a bulb....got a new one fitted, blew staight away. Just hope the garage that fitted it in april provide a 1 year parts warranty...otherwise its a bill i dont really need before xmas! lol.

hope youve got the problem sorted.

If anyone else out there knows what the problem could be...if it is in fact the body computer, again on mine especially lol...please feel free to add!


fordy31uk is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , blowing , lights , side

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome