147 electric windows - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-10-09 Thread Starter
Status: -
AO Member
Join Date: Oct 2009
Location: United Kingdom
County: Lancashire
Posts: 40
147 electric windows

Hi just a quick question,my drivers side lecky window works when it feels like it.If i wind it down,sometimes it wont go back up,unless i give it a good crack wi the back of my hand.Crude but it works,shall i leave it till next summer to have a look,or is it a simple fix.First day of ownership for me,and first problem,ere we go eh!
firestorm1000 is offline  
Sponsored Links
Status: Driving 400 to devon and back!
AO Member
GT_Birmingham's Avatar
Join Date: Mar 2009
Location: United Kingdom
County: West Midlands
Posts: 160
welcome to the window fix.

Put the window down all the way and hold the button for 10-15 secs. They put it up and do the same.

This will reset them.

I have had this on my GT and my new 147

Just keep doing it over and over and the problem with go.
GT_Birmingham is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , electric , windows

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome