motor control failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-10-09 Thread Starter
Status: 5 months
AO Member
yorky's Avatar
Join Date: Jul 2009
Location: United Kingdom
County: West Yorkshire
Posts: 144
Images: 1
motor control failure

driving home tonight, i thought i would give it some down my local stretch of road. i noticed it struggled to get up to the top of the rev range and have a bit of power loss. As soon as i slowed down again and tried to pick up on throttle it juddered not unlike struggling for fuel, then management lights flashed and the onboard computer informed of a motor system failure. The engine composed itself and the lights went out. There has been a bit of hesitation from 3k revs for a while and i think what i did has agrivated the problem. Has anybody had simular problems or know what could be going on before i spend money i havent got. By the way its a 2005 156 2.0jts. Dave
yorky is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jun 2008
Location: United Kingdom
County: Worcestershire
Posts: 275
Lack of power is usually worth checking the MAF first, but they don't usually flag up MCSF.
Phear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

control , failure , motor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome