VDC and ABS System Failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 07-10-09 Thread Starter
Status: AO Member
AO Member
Join Date: Mar 2009
Location: United Kingdom
County: Kent
Posts: 29
VDC and ABS System Failure

Have both VDC and ABS system failure warnings on dash, I have had an intermittant warning re number plate lights and side lights on starting car for the last couple of weeks, are these related???
I have read previous threads and could possibly be battery or fuse problems.
I have Alfadiag, will this help me.
It's a 2002 147 2.0ts Selespeed, about 36,000 miles.

Any help or advice much appreciated.
beanz is offline  
Sponsored Links
Status: on a mission
AO Member
Join Date: Jul 2006
Location: Ashford, Kent
Posts: 143

Member car:

147 1.6ts lusso

If it is still on the original battery then replace it,that worked for me on my 52 plate 147 and have had no warnings since.
twig is offline  
Status: Sold the 147
AO Member
Warsash 147's Avatar
Join Date: Mar 2007
Location: Southampton
Posts: 443
Images: 1
Hi - I had exactly the same on my 147. It wasn't the battery though as it still happened after my battery was replaced after it died. It got progressively more frequent over approx 2-3 years from occasional to every time you went out. Eventually diagnosed as a faulty brake light switch - not expensive, cost around 50 inc labour & the job included fitting a new crankshaft sensor (that was another problem - unconnected with the ABS / VDC warnings). I do still get the odd faulty bulb warning but switching the lights on & off usually cures that one.
Warsash 147 is offline  
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
The battery is a good place to start on this problem, bt have you confirmed that the bulbs in question aren't blown? If they aren't and the warning for them continues it will mean a new body ECU in the worst case, there are other checks to do before it gets that serious, but yes the battery will probably cure everything in this case.
Smaky is offline  
Status: -
AO Silver Member
corbo's Avatar
Join Date: May 2008
Location: United Kingdom
County: Somerset
Posts: 1,610
I had the same lights, was fixed with a new battery. I'll still get it if I wash the car with the radio on and run it low on battery juice. A quick blast to recharge soon fixes that.
corbo is offline  
(Post Link) post #6 of 7 Old 09-10-09 Thread Starter
Status: AO Member
AO Member
Join Date: Mar 2009
Location: United Kingdom
County: Kent
Posts: 29
Cheers guys.
Probably was the battery running low, had not used the car for about 5 days when the problem occured, but it seems to have sorted itself out, will definately get new battery if I get the same problem.
beanz is offline  
Status: Looking for Add ons
AO Member
Sharpshooter's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: Kent
Posts: 578
Images: 5

Member car:

Alfa Romeo 147

If you look by the ABS Pump (Behind the battery on the inner arch where all the brake pipes go in) there is a big plug in front of it. I had to drain mine yesterday and clean it out. If you remove the plug by levering the latch thats on the top, then draw it upward as you go. Have a look and see if there is any water or corossion on the connections. There are about 50 of them.

Once dry, a very small amount of WD40 and replace the plug. Blow it all out with air if you can.

Hope this helps.


Sharpshooter is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

abs , failure , system , vdc

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome