156 v6 cutting out - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 26-09-09 Thread Starter
Status: Prototipo
AO Member
yeosport's Avatar
Join Date: Feb 2008
Location: United Kingdom
County: Surrey
Posts: 174
Images: 10

Member car:

2000 156 2.5 v6

156 v6 cutting out

Hi there,

My v6 is cutting out occasionally and mainly when cold.
This seems to be worse when heating is running, lights on etc and braking, ie: fully loaded electrical system.Also has happened when turning on full lock and braking.
Would this point to MAF? i have had the lambda checked and it is running perfect lambda. Also throttle body and butterfly are all clean. Tried throttle and ecu reset but seems ok for a day or two then plays up again

yeosport is offline  
Sponsored Links
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,620
Throttle pipe split? If not, try unplugging the MAF and see if it drives any better.
Pud237 is online now  
Status: -
AO Silver Member
Ajr's Avatar
Join Date: Feb 2009
Location: United Kingdom
County: West Midlands
Posts: 1,063

Member car:

156 V6

start it, Remove the Battery and see if it stall /Cuts out.

Full lock lowers ur revs by 200Rpm
Fans, Lights ect also attacks ur electices.

i fitted a 2000 watt amp in a fiesta xr2, At full load it could stall the engine.
Ajr is offline  
Status: -
AO Member
GavinH's Avatar
Join Date: Jan 2007
Location: Ireland
County: Sligo
Posts: 488

Member car:

156 V6, GTV V6

Sounds to me like MAF..
GavinH is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , cutting

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome