really bad judder when releasing clutch. - Page 4 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Well not touched the car since saturday after being tied up with work and waiting for the last few bits on order

Finally got everything back together yesterday and cranked her over, started up straight away with no shaking

Did ok considering i did everything on my own apart from lifting the box back up.

Had a nightmare with some bits, had to order a new gear linkage clip, a new circlip for the clutch slave cylinder get 2lt transmission fliud and a new front pipe.

It drives lovely now, smooth clutch pedal and smooth changes. all the juddering and shaking has completely gone.

Had a clutch alignment tool already which helped a lot, and had to customise 2 tools. A 13mm Spanner which i bent in 3 places and i had to get out the angle grinder to shorten an allen key to get to the middle bolt on the Slave Cylinder bracket.

Bits bought:

20 Second Trolley jack to help lift the gearbox back in,
158 Valeo 3 piece Clutch Kit,
26 Brand new Clutch Slave Cylinder,
2.70 Circlip for slave cylinder
15 3 Manifold gaskets,
2 Clip for gear linkage bracket,
45 Front Pipe,
20 3 Front pipe Gaskets,
18 New Auxiliary Belt,
5.50 Dot 4 Brake fliud for Hydraulics,
20 2Ltrs 75w/90 GL5 Transmission Fluid

Total: 332.20

Not bad seeing how much i've changed and renewed. I know whats been put on and that its been done right and saved a packet at the same time!
Managed to get extra jobs done at the same time with the engine down such as new Drive belt and the front pipe needed doing desperatly.

Only thing to sort now, recheck gearbox oil level, and try to move position of the exhaust as with the new front pipe its sitting a little lower and is now sat on the rear anti roll bar, sounds lovely lol

All in all a good job done.

I'll post some pics up of my tools and a couple of the bay later.

Sponsored Links

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bad , clutch , judder , releasing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome