Manifold Blowing - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-09-09 Thread Starter
Status: -
AO Member
Join Date: May 2008
Posts: 25

Member car:

alfa 147

Manifold Blowing

A common fault on the alfa 147 is the exhaust bracket snapping but has anyone had trouble with the exhaust manifold blowing.

Well i did and I am not sure whether this is a common thing but it appeared to be blowing though the actual manifold pipes where they are pushed into the manifold plate (that is bolted to the engine block)??

I stripped the manifold and cats off and had all the pipes welded and the dreadful, **** bracket welded too. I also changed the gaskets but they all appeared fine and did not indicate any signs of blowing.

Seems okay now but I was curious as to whether this is common??

I have also noticed recently that I have a slight misfire at idle?? Does anyone know if this is likely to be some sensor giving the wrong reading as it is defo not apparent when driving so I doubt its plugs or coil etc....

Cheers people
camel305 is offline  
Sponsored Links
(Post Link) post #2 of 2 Old 12-10-09 Thread Starter
Status: -
AO Member
Join Date: May 2008
Posts: 25

Member car:

alfa 147

Misfire at idle

Turns out, after changing the clutch, that the outside casing on the cats were slightly cracked causing the exhaust to blow from what appeared to be the manifold.

However, I still have no idea what is causing my slight misfire at idle?? Any ideas???

camel305 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

blowing , manifold

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome