Few Issues needing help with - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-09-09 Thread Starter
Status: -
AO Member
Join Date: Sep 2009
Location: United Kingdom
County: Down
Posts: 13

Member car:


Few Issues needing help with

Hi folks,

I'm just new to alfa ownership and have a few wee queries. I've just bought a 1.6 147 and have the following issues,

Flashing odo: (I assume it thinks it needs a service or something??)

Car sounds like a diesel when ticking over

And finally:

The cruise control and remote key fob locking don't work. Now i've changed the batteries in both key fobs, and checked the relivant fuses which are ok, but still both not working

Anyone able to shed any light on the above issuses?????
Any help would be much appreciatted.
gpaevo is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,076
Sounding like a diesel on tickover is normally a worn variator - the device on the inlet cam that changes the valve timing above 3000 revs.....its oil-pressure operated, and when it gets worn it gets rattly. Changing it means a cambelt change, so most people put up with it until a belt change is due (every 36K miles or every 3 years). I've never heard of an engine failure arising fro a worn variator, so don't worry too much......
rgwm is offline  
Status: -
AO Silver Member
Join Date: Aug 2005
Location: United Kingdom
County: Bristol
Posts: 1,556

Member car:

Alfa GT

Flashing odo, the 147 uses a canbus system.

Basically if anything on the canbus is at fault, or has been removed then the odo will flash.

Had this on the GT once, just took it to my specialist and he reset it. Never came back
V6Alfisti is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

issues , needing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome