2003 156 2.0TS Selespeed - asking for trouble?? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: happier today
AO Silver Member
merlin's Avatar
Join Date: Jun 2006
Location: Kent
Posts: 2,437
Originally Posted by cj romeo View Post
A sele will definitely go wrong at some stage, and people who can deal withthem are ew and far between, its not that its all that complicated, its just that they are alien to most spanner monkeys.
Who says............... I've got 65k on mine and it's perfect,same year as the one here.
merlin is offline  
Sponsored Links
Status: -
Join Date: Jul 2012
Location: United Kingdom
County: North Lanarkshire
Posts: 2
Help,want another Selespeed.Old one packed in ,usual,Autopump/Actcuator/Solanoid?

Hi there im a lady driver,love my Selespeed totally ,so much id do anything to keep her,but costs keep rising,a year ago the Automatic went it would allow me to drive in certain gears,which i put up with,as Alfa Garage wanted 4G to fix and local garages just turn me away.She broke down completley in London ,RAC said wot i knew its the Autopump/Actuator/Solonoid plus blew the 30 amp fuse,So to replace would be over 2G.Again not affordable.Now ive spotted a 156 Estate Selespeed veloce,with 79000 on clk,and im heading down to London Tonite to pick it up.My Man is not speaking to me,dosen,t want another Alfa .But im smitten.Is there any local garages in North Lanarkshire Area.???????
Denim4venim54 is offline  
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
in the long run and with inadequate maintance every vehicle (or plane for that matter) will break down !
and as said before, selespeeds are not for the hamfisted mechanics !!
I always advice sele owners to master some simple technics with alfadiag, Multiecuscan etc and a proper
OBD cable ... important for seles : pressure (50-55 bar) clutch rod lenght (28-29 mm) and tutela oil that
stays on the max ... its that simple !
and once a year a calibrate routine, all can be done without getting greasy hands !
see youtube rarebear14 for a demo on my 156 sele !
rarebear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 2003 , 20ts , selespeed , trouble

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome