Strange noise - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-09-09 Thread Starter
Status: No remission for LUFC !!
AO Silver Member
ronan's Avatar
Join Date: Aug 2009
Location: Belfast
County: Down
Posts: 3,043

Member car:

156 1.8 Turismo

Strange noise

Just had 156 2.0 ts engine swapped....2 strange noisesne a dim screeching noise seems to be coming from belt bearing ?

Second one wasn't there when i picked it up from mechanic 75 miles away but sounds like a broken front box exhaust except it seems to be coming from the engine.

Any ideas,chaps ?
ronan is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
there are many idlers an tensioner to look at. One way to narrow it down is to flip the aux belt off and see if the noise goes away. If it doesn't then i'd worry a little as its on the cambelt. If it does then you can find out in your own time. As for the blowing noise. The flex joint on the down pipe or a split in the manafold. I've had both and they sound like you describe. Hope that helps a little
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

noise , strange

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome