147 1.9 JTD vibrations on idle - again - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
lost's Avatar
Join Date: Oct 2010
Location: Croatia
County: Sisak-Moslavina
Posts: 12

Member car:

164 v6 12v

how much does repair for injectors costs?
lost is offline  
Sponsored Links
Status: -
Join Date: Apr 2014
Location: Romania
County: Cluj
Posts: 3
Hello guys. I have my alfa 156 1.9 jtd 85 kw from 1 year and i have some vibration on idle. I change the DMF and clutch because the vibration was big when i start in 1 gear. What can be the cause of the vibration? Cambelt is new, engine pully new, alternator pulky new, alternator belt and tensioner new, engine mot from gear box new and engine mout close to shock absorber is the same new. And one more thing: when i drive for example in 4th gear if i leave the gas pedal fast and push again i hear som clanc/clanc....
Any idea is very good for me so please little help....
coasamihai is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , idle , jtd , vibrations

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome