cambelt probs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 30-08-09 Thread Starter
Status: No remission for LUFC !!
AO Silver Member
ronan's Avatar
Join Date: Aug 2009
Location: Belfast
County: Down
Posts: 3,043

Member car:

156 1.8 Turismo

Hmmm cambelt probs

New member

156 year 1999.....slipped cambelt.....16 valves car or 2nd hand engine ( quoted at 1000 fitted.

Which option ?

ronan is offline  
Sponsored Links
Status: - Update
Posts: n/a
New car maybe a tad drastic

Has the 2nd hand engine been reconditioned with new belt etc?

Third option = fix up

Good used 2nd hand heads & replacement big end shells etc mebee
Status: enjoying ma julie
AO Silver Member
belfast bob's Avatar
Join Date: Dec 2007
Location: United Kingdom
County: Antrim
Posts: 2,890
jon, i just gave him the opposite advice on his other thread on this

well, i would use the opportunity to change and use as donor if the 156 is stock and not too 'emotionally valuable'.
belfast bob is offline  
Status: - Update
Posts: n/a
Fair do's Bobby - tis all opinions

more than one thread doesn't help anything does it?.....

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

cambelt , probs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome