147-problems since owning or very reliable? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: that time again
AO Platinum Member
Guili's Avatar
Join Date: Aug 2008
Location: South Africa
County: Mpumalanga
Posts: 13,703
Images: 7
Hi guy...good car you getting, I feel because of their popularity they've been neglected by NON-Alfa lovers who've owned them...

first thing to watch out for is Service History...esp cam belt...not only belts, the whole deal, variators as well, if its not done work this into your deal when you buy one.

New batery - an old one will aparently pop up a lot of error codes.

Some of them are very thirsty when it comes to oil...I get an urge to stop some 147 woman drivers when I see their car smokes like crazy...but then they think I'm a nutcase when I ask them to pull over...their cars will unfortunately not last long.

Get the 2.0, as the 1.6 will only make you want a 2.0 more and more.

I've owned mine for 8 months now and I've only replaced a light bulb, had one normal service, and brake pads...

I also had clutch trouble and I'll have to replace it soon...this weekend in fact - coz I've been driving the car very hard since I got it

Oh, other things to consider...Twin Spark means more spark plugs...normally they get changed at 100 00km's so too the cats as they get clogged up...make sure they're changed mate, if not, work it into the deal again!

Other than that, grip that bulky steering wheel, sit back in that leather...and look around the cabin...what else is so sexy???

Alfa Romeo 156 Sportwagon 2.5 V6 - Project Swagon
Alfa Romeo Giulietta QV Tuned SOLD
Alfa Rommeo GTV Tuned SOLD
Alfa Romeo 156 GTA Sportwagon SOLD
Guili is offline  
Sponsored Links
Status: Gutted on having to sell the V6
AO Member
Hull04's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Greater Manchester
Posts: 86
Images: 30

Member car:

alfa 147JTD

I've had mine for a year now and Ive had 20000very happy miles in it and an EGR valve apart it's been reliable
Hull04 is offline  
Status: -
Join Date: Dec 2011
Location: Netherlands
County: Noord Holland
Posts: 1

Member car:


puddle of water in car

finding alot of water in passenger side of car...has anyone any idea where its coming from??
steve.b is offline  
Status: DEFCON5
AO Gold Member
1of1's Avatar
Join Date: Oct 2010
Location: Sao Tome and Principe
County: Principe
Posts: 11,605
Images: 7
Check chamber under scuttle panels for blocked drainage.
1of1 is offline  
Status: alfa 147 ts lusso
Join Date: Feb 2012
Location: Ireland
County: Clare
Posts: 6
Images: 4

Member car:

alfa 147

Hi only had my alfa 147 for 10 months. exellent car stunning looks fast and Averages 137 mpg would reccomend you get a 147 lusso. more toys in the cab.....
steevee1 is offline  
Status: alfa 147 ts lusso
Join Date: Feb 2012
Location: Ireland
County: Clare
Posts: 6
Images: 4

Member car:

alfa 147

only problems so far is creaking under both front arches. Had 2 new wishbones fitted before i bought it so i dont think it will be a problem to sort. other than that it a nice car
steevee1 is offline  
Status: -
AO Member
Join Date: Oct 2011
Location: United Kingdom
County: Kent
Posts: 276

Member car:

147 2.0

Electrics seem to be the biggest problem.

I've owned two 147's and both have temperamental electric issues. Something which I've not encountered on any other car. Coincidence? Once you're used to an Alfa it's not a big issue, but for a new owner it'd be a scare getting 'VDC Failure/ABS failure' just because a switch needs a clean.

Neither of my Alfa's have broken down on me.

Great cars though.
Newcard is offline  
Status: -
Join Date: Sep 2012
Location: United Kingdom
County: Aberdeen
Posts: 1
Love my alfa aka TuStacey. She a dream t drive but my bulbs keep going pop ?dunno? Alternator went at 50002 t be exact.

Thrash or not thrash? A good thrashing don't hurt anyone.

Why do I hear my mechanic rub his hands when I call him lol.

I have a lusso with lots of things to play with

Will upload a pic of her as soon as I know how
Ang33 is offline  
Status: -
AO Silver Member
scottyf's Avatar
Join Date: Jun 2012
Location: United Kingdom
County: West Midlands
Posts: 5,173
Images: 26

Member car:

Alfa 166

Last 4 months of ownership and 4500 miles on a 10 year old Alfa Romeo withhold 108k on it.

Front wiper linkage broke after 1 month
Variator now makes noise

However I've spent more on modifications than anything.

A girl at work has the same albeit higher spec lusso and she's done 30k on a 600 Alfa 147 and she's not had a single problem. An she's driving that into the ground.
scottyf is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147problems , owning , reliable

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome