Expensive to Run My A**e - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: I'm not a real Dr.but I'll have a look
AO Member
drbagiva's Avatar
Join Date: Feb 2008
Location: United Kingdom
County: Nottinghamshire
Posts: 21
Had our 156 2.4 for around 20 months now.As it was 5 yrs old when we got it we had a new cambelt fitted(thanks Lewis,Alfa Romeo Specialist). I fixed the non working heater airflaps (radio/flap conflict)..Just had 4 new budget tyres fitted (shame on me) and laser tracking front+back and 2 services. Now that's cheap motoring!
Still need to get aircon working tho'
drbagiva is offline  
Sponsored Links
jay w
Status: - Update
Posts: n/a
Originally Posted by Smaky View Post
Well I can do them done for less than that and it's only 1 job altogether with spends for a pub lunch left over.
Fair point Smaky...

Alfa clutch and rear main oil seal just cost me 250 and the stainless exhaust will make up the rest of that cost i imagine...

Still i have hand brake cables to do after that and one of the rear suspension bushes as well...

By Xmas it will need a new cambelt, water pump, variator and aux belt doing, and i would imagine tyres will be next on the hit list after that....

I know that sound like a lot but it's doing on average 500-750 miles a week, every week

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

expensive , run

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome