squeaking/chafing from front - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
jay w
Status: - Update
Posts: n/a
squeaking/chafing from front

recently i have notice that there is a chafing noise coming from the front of the car, it sounds like the undertray is dragging, but it isn't.

only when the car is cold and coming from the O/S, i would imagine its the bushes, can anyone confirm this?

Sponsored Links
Status: -
AO Member
Join Date: Jul 2009
Location: United Kingdom
County: Essex
Posts: 339
possibly a worn wheel bearing... they sound worse when cold until they heat up and expand, reducing the gap created by wear n tear...

djlat is offline  
Status: - Update
Posts: n/a
Squeaking from the front could be the upper wishbone - mebee give the bush a blast of silicone & see if it quitens before looking at anything else

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

front , squeaking or chafing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome