Funny battery issue - 2.4 JTD - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 25-08-09 Thread Starter
Status: -
AO Member
Daytona's Avatar
Join Date: Jun 2006
Location: United Kingdom
County: Greater London
Posts: 744
Funny battery issue - 2.4 JTD

I've had 2 Sportwagons ( 2.0 TS & 2.4 JTD ), and they both suffered from occasional battery drain, where I'd come out in the morning and the battery could barely turn the engine over. I checked if any interior lights where left on etc. ( which they weren't ). It seemed to be that this would happen if I left the face on to the cd/radio. SO two questions are:

1) Why would this happen?

2) And when I try to start, the engine would turn over a few times - then I'd charge the battery. When I replaced the battery, and with everything turned off and key out - when I connected the battery the engine would continue to try to turn over. Why would it do this when the key is not even in the ignition? This seems peculiar to my current JTD.

Daytona is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

battery , funny , issue , jtd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome