Uneven tickover 156 1.8 ts - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 23-08-09 Thread Starter
Status: -
Join Date: Sep 2007
Posts: 5

Member car:

alfa 156

Hmmm Uneven tickover 156 1.8 ts

Since I got mt 156 1.8 ts, the economy has been terrible. It has been on a diagnostics computer which showed no fault other than running rich. I have since found that the thermostat was stuck open. On replacing, the temperature now comes up to 90 (it barely moveds before), but after being revved the tick over goes between 500 and 2000 rpm several times before settling down. Has anyone any ideas what to check next?
jjohnson is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
MAF sensor possibly. Is she still running rich cos it could be lambada sensor too.
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , tickover , uneven

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome