Car pulling under braking, and vibration at higher speeds! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-08-09 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Location: South Africa
County: Gauteng
Posts: 130

Member car:

Alfa GQV

Help Car pulling under braking, and vibration at higher speeds!

As i said, if i brake from about 60km/h to 0.. hard. THere is no issue, but hard braking from about 110, it pulls to the left quite sharply. Also under light braking from about 120km/h the steering wheel vibrates ?

is this a warped disc, a caliper not working or what ?

replacing the variator soon :P so might aswell get it all done in a weekend.

oh and its a 147 1.6
Waziboy is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
I'd say your first bet is discs. The part of the caliper where the brake pads slide may also have corrosion on it. Clean it up and see if the problem of pulling to one side persists
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

braking , car , higher , pulling , speeds , vibration

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome