help!Advice needed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 16-08-09 Thread Starter
Status: -
Join Date: Aug 2009
Location: United Kingdom
County: West Yorkshire
Posts: 1

Member car:

156 selespeed

help!Advice needed

I recently (last weekend) purchased a 1999 156 selespeed, (my 3rd 156).
Anyway all was well, full history, complete engine rebuild 3 years &20k ago due to a snapped cambelt, complete with bil for 1180,engine ran sweet as a nut no rattles knocks etc.
Driving down the m62 yesterday, the injection light came on and the car started to lose power,as i slowed down there was a bang followed by a lot of smoke, and the contents of the car engine dumped on the motorway. I am told by my father in law that the 3rd conrod has blown a hole in the engine.I am absolutely gutted. So my questions are- will i need a complete new engine or can i get away with a new bottom end?( i know very little about engines!) would it be better to get a doner car to drop the engine out of it and if so does it have to be a selespeed or would the engine from a manual 156 do? the alternative is to break the car which i really dont want to do as it just seems to good. I would really appreciate any advice you can give. Thanks!
stew748 is offline  
Sponsored Links
Status: -
AO Member
qawsed's Avatar
Join Date: Mar 2008
Posts: 569
Images: 2
New engine might be cheapest option.
qawsed is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

helpadvice , needed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome