HELP!!!!! Evyerthing on steering wheel not working - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 12-08-09 Thread Starter
Status: -
Join Date: Nov 2008
Location: United Kingdom
County: Greater London
Posts: 6

Member car:

***** 147

HELP!!!!! Evyerthing on steering wheel not working

Hi Everyone, i'm hoping someone can advise me on what the problem is or at least give me an idea. I own a 147 and Everything on my steering wheel does does not seem to be working, i;e the wipers are not coming on, the lights and indicators are not working either, and the horn is not working. The only thing working seems to be the controls for the radio. Does anyone know what might be causing this and also where i could possibly get this fixed. I live in North West London. I must say very frustrating at the moment.

Thanks all!!!!
jaymwila is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

evyerthing , steering , wheel , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome