engine management light reduced power - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 09-08-09 Thread Starter
Status: -
Join Date: Aug 2009
Location: United Kingdom
County: Down
Posts: 2

Member car:

156 2.5 V6 24V

engine management light reduced power

Hi all could someone plz help me. i drive an 2001, 156 2.5 V6 alfa and at the minute the engine magagement light is on. i took it to an autospark and it threw the code up p0220. he reset the light and i got 3 more days driving before it came back on. we reckon its the pedal sensor but how can we be sure. is the sensor a bosch part also??? the car has reduced power but not all the time and you can feel it sometimes when your driving like its holding back. thanks
andyr is offline  
Sponsored Links
Status: -
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646
sounds like throttle pot issues

TPS/Pedal Position Sensor/Switch B Circuit Malfunction

there is a 'fly-by-wire' system in your car.

there is a connenction *somewhere* behind the glovebox/radio area that can cause issues & another at the throttle pedal itself.

Jon Nom Nom had similar issues a while back
SEARs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , light , management , power , reduced

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome