Changed the spark plugs.. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 05-08-09 Thread Starter
Status: -
AO Member
Join Date: Sep 2007
Posts: 16

Member car:

156 2.4 JTD

Changed the spark plugs..

... and now it goes like a train!

Had my 147 for a few weeks now and never thought it was going quite as well as it should. It was due a spark plug change anyway, so I did them this morning (put NGK platinum-electrode plugs in). The old ones looked rather worn out, particularly the single-electrode ones, but they had all been firing.

Went for a quick test drive afterwards, and apart from a false warning about all the sidelight bulbs being out (cleared when I turned it off and on again) it went beautifully! It's now pulling much harder at low revs, well worth the expense. Following 2 years of trouble-free Alfa diesel ownership, I now see what all the fuss is about regarding the twin spark!
brewnog is offline  
Sponsored Links
Mario Andretti
Status: - Update
Posts: n/a
Good to hear that she is going well now for you...

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

changed , plugs , spark

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome