Radio & Info screen have defaulted back to Italian after battery change - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 02-08-09 Thread Starter
Status: -
Join Date: Aug 2009
Location: United Kingdom
County: Durham
Posts: 1
Hmmm Radio & Info screen have defaulted back to Italian after battery change

After changing the battery on my 04 sportwagon 156 the radio and centre information display have defaulted back to Italian. The radio has the integrated telephone keypad which can have a SIM card inserted. I have entered the radio code and the radio works ok but all of the phone menus are Italian. The upper display on the centre of the dashboard which has the date in it is also Italian. I can still navigate through and find the tyre pressures,service info etc.

Does anyone know the procedure to change these back please.
T19PPS is offline  
Sponsored Links
Status: - Update
Posts: n/a
learn italian
Status: -
AO Member
Join Date: Feb 2009
Location: United Kingdom
County: Somerset
Posts: 205
I'm sure this is one of the options when you scroll through the 'Menu' along with mph or kmph etc. Just hit the menu button and press + until you get to the language option and try and recognise Inglaisi or something like that
handful is offline  
Status: Just when you thought it was safe mwahaha ;)
AO Gold Member
Alfa-Red's Avatar
Join Date: Jan 2009
Location: United Kingdom
County: Lancashire
Posts: 6,811
Images: 8
english in italian is inglese

should be in the options, just scroll through to lingua
Alfa-Red is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

back , battery , change , defaulted , info , italian , radio , screen

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome