Air Con Inop - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-07-09 Thread Starter
Status: -
Join Date: Jul 2009
Location: United Kingdom
County: East Ayrshire
Posts: 1

Member car:

alfa romero 147

Air Con Inop

Hey fellas got me a wee 147 2000cc,Air con was inop when bought found a spilt pipe which has now been changed out,got it gassed up again to be told it took a charge but the temp is all over the place.So i still aint got any air con and no idea whats next to check.

Any ideas ??????

brasco79 is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Who charged it for you?

Have a look at the a/c compressor at the front/left of the engine. Does the 'middle bit' spin when the engine is running, and the a/c is switched on?

Has the pollen filter been changed recently?

If you're getting cooling, but irregularly, I'd suspect the cabin temperature sensor(s?), which on the 156 is in the centre console...
iainfm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

air , con , inop

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome