faulty ecu..?? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 20-07-09 Thread Starter
Status: -
AO Member
alfa156man's Avatar
Join Date: Jun 2009
Location: United Kingdom
County: Northamptonshire
Posts: 10

Member car:

156 jtdm16v

faulty ecu..??

hi wonder if anyone has any ideas on this one....had 156 16v jtdm for three months 53 plate,it's done a lot of miles 126k,however engine is sweet and looks great.getting motor system failure and rev limit.first.second,third ok.4,5,6 3k limit...been to garage for diag test,he cleared codes,drove till light came on again(15 miles)..got code p0601..faulty ecu,however he said aint too sure tho as they rarely go faulty....had loose battery lead maybe this could of affected ecu(spiking)..oh the warning light came on for sys failure for the first time at the same time low feul light came on,sometimes feul gauge gives false reading's...should i send ecu to be tested or get wiring checked out first..this car is great when i get a day with no failure light..goes like the wind
alfa156man is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
Had the same problem with my jtd mjet. Same fault altough without the fuel gauge light. rev limit with motor failure light. Took to alfa. Reset. Made it a mile up the road. Came back and had it reset again. Made it about 10!!! Turned out to be a faulty MAF sensor. They did suggest a leaky fuel injector too so if its not the MAF it could be that.
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

ecu , faulty

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome