ahhh! anyone know... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-07-09 Thread Starter
Status: -
AO Member
Join Date: Mar 2009
Location: United Kingdom
County: Kent
Posts: 13
Help ahhh! anyone know...

Hi all, having ongoing issues with my 03 JTS 2 Ltr -can anyone advise...
Ive just replaced the hose that runs from the right side of the cam cover (connects to the black Y piece thing) the other end of the hose connects to a plastic union that sticks up vertically just behind the throttle body near the bulkhead.

I get a constant hissing/rasping noise from the area around this union (revs blip a little when engine idling due to this leak). Checked the new hose I fitted and its ok so sure its the union area thats leaking. On this union I can see a small metal tab thing towards the bottom of it - can this metal bit be pulled out and the union disconnected from the (rear) throttle body, or is the union a sealed unit?

I pulled the old hose rather hard to get it off and wondered if there is a O ring inside the union that I could have damaged? I don't want to have to get a replacement inlet manifold unit if I dont have to!
Any thoughts gratefully received!!!
newtoyjts is offline  
Sponsored Links
Status: -
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646
you got a picture of the part in question?
SEARs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome