alfa 147 electric fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 18-07-09 Thread Starter
Status: -
AO Member
Join Date: Feb 2009
Location: United Kingdom
County: Norfolk
Posts: 17

Member car:

ALFA 156

alfa 147 electric fault

My 147 has electrical problem. Display on dash shows all faults, ie low pads, low brake fluid etc. advised needs new body computer at a cost of 400 !!!. CANNOT FIT SECOND HAND ONE. IS THIS THE CASE OR OTHER SOLUTION?
ginella is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jul 2009
Location: United Kingdom
County: Leicestershire
Posts: 29

Member car:

1.6 147 T.Spark

Wow. I had that awhile ago when I left my car sitting for a month because the power stearing fluid was leaking. But after I worked on it, and got a new batt (as it died from sitting there being unused), all of these fault messages soon went away.

How long has this been happening for? Who advised you that it needs a new computer?
Rishi C is offline  
Status: -
AO Member
adf83's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Surrey
Posts: 438
The general opinion is that erratic electronics are often caused by a weak battery. I would check the condition of the battery first and replace if necessary. These faults often seem to disappear with a healthy battery, which will cost a hell of a lot less than a new computer.
adf83 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , electric , fault

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome