Sluggish 156 SW, spark plug renewal intervals??? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 16-07-09 Thread Starter
Status: Trying to like my Alfa again!
AO Silver Member
KNIEVEL77's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: -
Posts: 2,412
Sluggish 156 SW, spark plug renewal intervals???

Following on from my last thread, i've just been out in my 156 in the wet and the steering seems much better BUT it still feels sluggish, as if the car is really heavy especially on acceleration. has now done 160,000 miles, spark plugs changed twice in that time at 60,000 and 120, you think renewing the plugs might give it a boost or a bit more zip!

It has just been in recently for its 156,00 mile service and they weren't changed then.

Last edited by KNIEVEL77; 16-07-09 at 21:59.
KNIEVEL77 is offline  
Sponsored Links
Status: -
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646
60k miles

also check the plug well for oil/water around the plugs

the sympthoms you describe could also be caused by a fialing maf, try disconnecting it too see if the power returns
SEARs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , intervals , plug , renewal , sluggish , spark

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome