Selespeed Recalibrated now working Need help with fault Codes. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 15-07-09 Thread Starter
Status: -
AO Member
Join Date: Nov 2007
Posts: 50
Selespeed Recalibrated now working Need help with fault Codes.

Hi just want to thank Phear for poping over and using the alfa diag on my selespeed today. After one failed calibration, and engaging each gear with the software and one more compleated callibration, I now have all gears engaging and the car runs. But there were some fault codes on the diag software i have read smakys great post and found the codes are

P1745 Line Pressure Solenoid System
P1746 Pressure Control Solenoid "A" Open Circuit
P1747 Pressure Control Solenoid "A" Short Circuit
P1749 Pressure Control Solenoid Failed Low

Could i please get some help on the meanings of these codes and anything that i can do to rectify them.

ALFA SHIRE is offline  
Sponsored Links
(Post Link) post #2 of 4 Old 16-07-09 Thread Starter
Status: -
AO Member
Join Date: Nov 2007
Posts: 50
Any one have any ideas could this be a lose connection are the connections easy to get to without a ramp?
ALFA SHIRE is offline  
Status: -
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646
sounds like your selespeed ecu is not seeing one of the 3 solenoids.

using a multimeter check the resistnace form the 20 pin connector.

look at the sticky thread, 1st post, for a link to a website with good schematics
SEARs is offline  
Status: new battery in, just need gears to work now...
AO Member
squealey's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Gloucestershire
Posts: 28
Just had nearly the same codes pop up on my alfa's diagnostic (mine had p1748 instead of 1749) did you manage to get any further on the problem? was it just the multi pin connector?
squealey is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

codes , fault , recalibrated , selespeed , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome