Rear wiper motor has died - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 14-07-09 Thread Starter
Status: -
AO Member
Join Date: Feb 2009
Location: United Kingdom
County: Midlands
Posts: 104
Images: 3
Rear wiper motor has died

Hi Guys,
The wiper motor on the rear of my 147 has died. I just wondered if anyone knows where I could get one for a decent price?
thefunkaygibbon is offline  
Sponsored Links
Status: -
AO Member
rossolusso's Avatar
Join Date: Jan 2007
Location: United Kingdom
County: South Lanarkshire
Posts: 302
Images: 12

Member car:

500 TA, VW T5

It will probably just be dried up with dust getting into the gear assembly its fixed to. Can be cleaned out quite easily yourself. Lots of WD and some new grease gets it going again,
rossolusso is offline  
Status: -
AO Silver Member
armoore's Avatar
Join Date: Jan 2002
Location: United Kingdom
County: Surrey
Posts: 3,690
Take it apart, it is fairly easy. The cover plate is secured using a number of small torx screws, once this is off you'll be able to see the gearing. The oval retaining plates may be prised away so that the spindle can be knocked out from the wiper end. The spindle seizes inside the outer tubing. The only tricky part is removing, and not losing, the tiny circlip at the wiper end. Then clean it all up and re-grease not forgetting the small rubber 'o' ring also at the wiper end. Takes about an hour to do.
armoore is offline  
Status: My 159 is a bird poo magnet
AO Member
Irish147's Avatar
Join Date: Nov 2005
Location: Ireland
County: Limerick
Posts: 387
Images: 1

Member car:

159 1.8 Turismo

If you are a lazy bugger like me you could get a second hand or reconditioned one, thats what I did, now I did take the old one out and did a mini service on it and the O rings but 6 months later it was back to its old tricks. Got the reconditioned one for 45 which is about 41 I reckon from Autolusso
Irish147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

died , motor , rear , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome