Engine management light fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 09-07-09 Thread Starter
Status: -
Join Date: May 2008
Posts: 1

Member car:

Alfa 156 JTD 20v

Engine management light fault

Right before I start any help would be very helpful as I am tearing my hair out.

I have a 156 jtd 20v with sytem failure mess keep coming on which says air sensor fault I believe so things changed are mass sensor and air sensor on manifold cleared fault but the error keeps coming back and saying same fault does anybody no what else it could be the car is driving really well since the changes and no more black smoke so im a bit stuck now at what to check next.

anyone with any ideas would really help!
rossi1979 is offline  
Sponsored Links
Status: -
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646
what is the EXACT code?

it might help us narrow it down.

so you ahve replaced the MAF & *something* else? or just the MAF?
SEARs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , fault , light , management

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome