Flashing Warning Lights With Dead Battery - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-07-09 Thread Starter
Status: wants his leather seast to stop squeeking!
AO Member
thegodplato's Avatar
Join Date: Jun 2009
Location: United Kingdom
County: Lancashire
Posts: 35
Help Flashing Warning Lights With Dead Battery

I have a 2.0 Ts on a W plate and, following on from other posts I've replied to, etc, have now had this happen to me.

Key will not unlock doors electrically, alarm de-activates and then I have to gain entry via using key in door.

Try to start engine and nothing happens.

Charged battery for 5 hours last night and got a slight cough out of the engine.

Have just had it on charge for a further 5 hours and still nothing. A slight cough then I get nothing except this :-

On the dash the Brake Pad Wear light and Seat Belt light start to flash, along with the speedo needle flickers and the yellow low fuel light flashes. The longer I hold the key in the start position, the faster the Brake Pad Weat Light and Seat Belt light flash.

I don't get a Low Battery Charge light.

If I then move the key to the MAR position I just get the normal warning lights that would come on and then go off when the engine is running.

I'm not the best electrically and having only just bought the car, had cambelt and service done, was looking forward to driving after giving it a good wax.

Flaming thing. I was warned when I got it, "Get an Alfa, get AA" by a friend. Perhaps he was right.

I don't mind if its only the battery if that is what it is, but if it sin't then...oh dear.

Oh, should I be able to jump start it using jump leads? Would this def prove its a nackered battery?
thegodplato is offline  
Sponsored Links
Status: All is well!!
AO Member
David156's Avatar
Join Date: Jan 2009
Location: United Kingdom
County: Cambridgeshire
Posts: 185
Sounds like the battery to me, just connect some jump leads and see if the problem still exist's.
David156 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

battery , dead , flashing , lights , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome