gt throttle sensor problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 04-07-09 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Posts: 11

Member car:

2004 gt

gt throttle sensor problem

Hi all , got a 04 plate 1.9 jtd gt with an intermittent fault gradually happening more often.
The engine management light is coming on and sometimes a loss of power but not always.
So went to a local garage where they plugged it into their diagnostic machine and came up with a couple of potential causes.
One was the throttle sensor and the other was the butterfly valve but they did admit to not being 100 percent sure.
Also the price they were asking to do the work was putting me off especially when they weren't sure this would cure the problem.
So if anyone has any ideas on the cause of the problem i would intrested to hear them.

almighty70 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

problem , sensor , throttle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome