hazard warning lights dont work - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 04-07-09 Thread Starter
Status: -
AO Member
Join Date: Dec 2008
Location: United Kingdom
County: Cheshire
Posts: 43
Images: 2

Member car:

156 2.4 jtd sw

hazard warning lights dont work

hi on my 156 jtd (face lift interior) i have no hazard lights at all, the indicators are fine, have checked fuses not sure what else it can be the only other thing is hazard switch dosent click like the others on the centre console
carlos39 is offline  
Sponsored Links
Status: - Update
Posts: n/a
The hazard switch is part of the climate control unit which is well known for having dry solder joints inside. If your handy with a soldering iron you can take it apart and re-solder the connections inside - or get someone else to do it for you.

the switch doesn't click as it is a momentary push switch - like a button on a calculator.
Status: -
AO Member
Join Date: Jul 2011
Location: Ireland
County: Dublin
Posts: 77

Member car:

Citroen xantia

Hi CraigM, same problem on a `04 facelift 156 1.6 Ti..........followed your advice.....got help from an electronics friend......first attempt was cleaning the circuit board, particularly the area around the hazard lights "switch pads" no fix......then redoing the soldered joints on the circuit board.....hey presto.......back in business. My electronics pal did it for me......very small soldering iron tip required and a magnifying glass.....delicate stuff !.........Thanks you`ve saved me a packet !. The temp sensor / fan unit is a bayonet fitting into the back of the module...care required to fit / remove.
dannyboy201062 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

hazard , lights , warning , work

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome