Before I take my GT back to Alfa AGAIN.... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 04-07-09 Thread Starter
Status: -
Join Date: Jan 2008
Posts: 3
Before I take my GT back to Alfa AGAIN....

2 weeks ago I had a full 5yr service from Alfa on my GT 3.2V6 (incl. timing belt, water pump, tensioners, plugs, rear dics & pad). 165 miles later on the motorway, my engine gives out, rattling like pots n pans, although it still had drive to bring it to a safe stop.
Alfa said the fault was due to the coil and had 2 of them replaced along with the spark plug seals. However, my GT just doesn't quite feel the same. Idle, it has little hiccups and the I can feel the enging wobble and it seems a bit down on power, although it does drive fine. Also, they filled my car with sweet perfume and after I rid the car of that scent, I'm picking up an acrid smell.
Any advice before I take her back. Thanks!
Mr Wright is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , back

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome