Stupid clutch pin!!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 30-06-09 Thread Starter
Status: -
AO Member
eL-ZilCHo!'s Avatar
Join Date: Sep 2008
Location: United Kingdom
County: -
Posts: 78
Stupid clutch pin!!!!

Well the clutch pin went again on my 147 today. It was fixed about 6 months ago by the dealer, after only owning it a month or so, and its broke already.

Anyone else had one go so soon?

I wouldn't mind so much, but its not as though I do a lot of miles. Annoyed

I'm sorry to say it but I am really begining to dislike this car, there's other annoying things about it too , I wish I'd kept my Punto - that was ace. Oh well, live and learn.

What exactly is this new improved pin they fit? Anyone know how it differs from the original one? I've tried searching but can't find any details.
eL-ZilCHo! is offline  
Sponsored Links
Status: -
AO Member
Tee-O's Avatar
Join Date: Aug 2003
Location: Naas, Ireland
Posts: 890
Images: 10

Member car:

GT Monza 1.9JTDm

mine went the other day aswell in rush hour traffic. Apparently it had the "upgraded" pin before it left the factory so didn't need the recall. From what I've been reading, the new pin is no better than the old pin, but a washer is put in aswell to slow down the friction and eventual snapping of the pin.

Seems a lot of GT & 147 owners on here are carrying spare split pins or terry pins, whatever they are in the car in the eventuality of it happening again
Tee-O is offline  
Status: - Update
Posts: n/a
Strange.....I have had my 147 since new (5 years old now) and its never gone. In fact nothing has ever gone wrong with the car...end of!

Status: -
AO Member
Join Date: Oct 2008
Location: United Kingdom
County: Cambridgeshire
Posts: 35
Happened to me before, wouldn't worry about it - its being held in with a bent old nail I found. Not gone wrong for the last 6 months
compaq1024 is offline  
Status: -
AO Member
paullec's Avatar
Join Date: Dec 2008
Location: United Kingdom
County: West Midlands
Posts: 610

Member car:


i have a spare pin in the ashtray to keep with me lol I more frustrated with the bloody creaking pedal.
paullec is offline  
Status: -
AO Member
Join Date: Feb 2009
Location: United Kingdom
County: Cardiff
Posts: 137
As I've mentioned before in similar threads, after the recall replacement broke after a couple of Kmiles I also reverted to a bent nail!
Il Diavolo is offline  
(Post Link) post #7 of 8 Old 01-07-09 Thread Starter
Status: -
AO Member
eL-ZilCHo!'s Avatar
Join Date: Sep 2008
Location: United Kingdom
County: -
Posts: 78
Well I've had it fixed again today, the garage is also sending me a spare one so i can keep it in the car.

Its clearly a bit of incompetent design. It would seem from looking the master cylinder isn't square to the pedal, so when it is compressed a lateral force is put on the pin. I'm not sure if there is a way to shim out the master cylinder mounting to square it up a bit, something to look at in future I think.
eL-ZilCHo! is offline  
Status: Ultimate Driving Machine my arse
AO Silver Member
Jim145's Avatar
Join Date: May 2005
Location: United Kingdom
County: West Yorkshire
Posts: 2,043
Mine snapped the week I got my GTA! I now have several spares in the glove box.
There is a thread on here showing how to space it with washers to prevent it from snapping the pin.
Jim145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clutch , pin , stupid

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome