GT Brakes poor - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 19-06-09 Thread Starter
Status: -
AO Member
djw1066's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: Essex
Posts: 171

Member car:


GT Brakes poor

Is it me or are the brakes a bit poor in general on the GT?

The pedal travel seems quite long and when braking hard a couple of times - e.g. at roundabouts on a dual carriageway - the brakes seem to fade somewhat.

Is there a way of rectifying the problem fairly cheaply -i.e. better pads etc. or is it basically that the whole system is under-specified?

(Mines a Diesel by the way)
djw1066 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Mebee change the fluid - when was it last done?
Status: On Alfa number 15
AO Platinum Member
symon's Avatar
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 33,562
Images: 13
Had the Diesel got Brembos?

Alfa's don't tend to have much servo assistance on the brakes which gives the initial impression that the brakes are poor. However you just need to push the pedal harder.

It sounds to me as if you have a disc/pad problem, maybe cheap pads?

Last edited by symon; 19-06-09 at 20:40.
symon is offline  
Status: El finto :(
AO Member
KendalBeefcake's Avatar
Join Date: Mar 2008
Location: United Kingdom
County: Kent
Posts: 886
Images: 4

Member car:

159 SW Ti

I'm not mega keen on mine either, defiantly a bit squirmy under heavy braking. The GT's come as standard with the 284mm discs, I've not seen any version with either the 305mm or 330mm brembos as a factory fit.

I was planning on to put in the Ferodo DS2500's, metal pipes and 5.1 fluid after the service as a first option, if that wasn't sufficent I was going to go for the 330mm brembo kit (apparently circa 1000+ to convert from 284mm), but that's assuming I can find the cash!
KendalBeefcake is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

brakes , poor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome