Squeek from pully area on tickover??? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 18-06-09 Thread Starter
Status: -
AO Member
Join Date: Jul 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 253
Squeek from pully area on tickover???

I've got a high pitched squeek from the front of the engine (2.4 JTD) but only at tickover speed. It's been in the workshop and they say it's probably a belt...it's not a belt, I am sure of that! I suspect an alternator bearing, possibly the water pump but if that starts to fail there is usualy water loss too. I think the garage is fobing me off because if it is anything like that they will have to replace under warantee! Has anyone had similar?
Alphataurus is offline  
Sponsored Links
Status: Frickin Awesome!!!
AO Silver Member
Prof Peach's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Northumberland
Posts: 3,801
Images: 13

Member car:


I had a similar problem. Narrowed it down to the Auxilliary belt tensioner. If you can get access to the pulleys, try spraying a little WD40 onto the tensioner wheel centre when the engines ticking over. If it goes quiet, you've found your culprit. £25-£30 part for my TwinSpark.

Hope that helps.
Prof Peach is offline  
Status: Silver Member
AO Silver Member
CroBaron's Avatar
Join Date: Jul 2006
Location: United Kingdom
County: Carmarthenshire
Posts: 2,230
Images: 8

Member car:

156 2.0TS

I got a squeak as well and I replaced the aux tensioner
CroBaron is offline  
Status: -
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646
afaik the aux tensioner ofr a JTD is quite expensive to buy as a seperate component.

also i believe in order to fit it that the engine has to be dropped at the belt side in order to get enough room to remove the old unit & fit the new unit
SEARs is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
If you want to rule out the water pump and fuel pump then take the aux belt off and run the engine up. If there is no noise then you can rule those out. If the noise persists then it may be a little more expensive.
Joss is offline  
(Post Link) post #6 of 6 Old 20-06-09 Thread Starter
Status: -
AO Member
Join Date: Jul 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 253
Going to have a look at the tensioner today. Thank's to all for your input. Let you all know result.
Alphataurus is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

area , pully , squeek , tickover

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome