Exhaust rumble at 2k - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-06-09 Thread Starter
Status: -
AO Member
Join Date: May 2009
Location: United Kingdom
County: Bristol
Posts: 46
Exhaust rumble at 2k

Hi guys i have a 156 2.0t.s and have a rumbling of the exhaust every time i hit 2k under load, I have checked the bracket that is in the engine bay and that is ok and secure, I have replaced the rubber hangers and this didnt help, and now i have run out of ideas.

Is there anything else i should could look at? This only happens at 2000rpm and under load.

Forgot to mention is an s plate 1998 if that makes any difference


steve001 is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
Could be as the engine twists on the mounts the exhaust is catching a heat guard?
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

exhaust , rumble

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome