Time for a new battery maybe... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-06-09 Thread Starter
Status: I don't know what goes here
AO Member
Join Date: Jan 2009
Location: United Kingdom
County: Cheshire
Posts: 250
Time for a new battery maybe...

Over the past few months, I have intermittently received the "low battery charge" warning, it's not regular, I could leave my car standing for ages and it starts fine and even other times I could drive it for 100 miles one day, and the next morning it'll give me that error, but it doesn't stay on or anything (unless it isn't meant to?) I had the battery tested and I cannot remember the exact figure but the guy who did it at Halfords with his meter said there were no problems with it that he could see, to warrant replacing the battery.

It's only gone flat on me once when I was changing bulbs and listening to stereo at the same time and then when I tried to start it, it was totally flat, though since then, I have disabled all interior lights from coming on thinking that'd prevent that happening or something, I dunno.

But anyway, it's still on the original alfa battery from new I reckon (6 years ago).

The only reason I bring this up though, is all Exide Premium car batteries are 33% off at Makro starting June 17th to June 30th, this is the second time this offer has come on and looks very good value for money

The Exide Premium 770 (77aH 760 A(EN) 12v will go down to 53.59 (exc vat.) It has that display as well telling you what color thingy the battery condition is in.

Does it sound like I could do with a new battery? and would does that offer sound decent enough? When I looked into getting one about a month ago, places like Kwik Fit quoted the same price but for like a bog stadard one etc.
nugget is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jul 2007
Posts: 725

Member car:

GTV V6 Turbo

Does sound suspect with just listening to the stereo making it go flat..

What are the connections to it like? Might be worthwhile checking those are are clean and tight
vela blue is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

battery , time

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome