156 Cambelt - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-06-09 Thread Starter
Status: -
AO Member
Join Date: Jan 2009
Location: United Kingdom
County: Hampshire
Posts: 51
156 Cambelt

I was topping up the oil on my 156 the other day and noticed that you could see the cambelt plain as day, Is this supposed to be like this as i always thought that they should be fully covered up to stop any crap getting in?? also i noticed that someone has broken the bottom of the cover at some point on the part that bulges out ( i can see a cog of some sort, balancer shaft maybe???)
Would anybody have a spare cover if this is wrong??
ferrarikid is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
The cambelt is supposed to be completely covered. You can see the aux belt though.
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , cambelt

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome