ticking noise from behind speedo - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-06-09 Thread Starter
Status: -
AO Member
tyrer81's Avatar
Join Date: May 2009
Location: United Kingdom
County: Merseyside
Posts: 63

Member car:

alfa 156 ts 2.0

Hmmm ticking noise from behind speedo

just notcied a ticking noise from behind my speedo when car is or isnt started tried a few switches (wipers /lights ) when i put my sidelights on it goes ????
any ideas please
x reg 156 2.0 ts
tyrer81 is offline  
Sponsored Links
Status: -
GingerViking's Avatar
Join Date: May 2009
Location: Switzerland
County: Vaud
Posts: 6
Strange... I noticed the same on my 2001 147 the other day... It seemed to be ticking in perfect time with the blinking ':' symbol (between the hours and mins) on the clock. It stopped after a bit...

I haven't noticed it since, but ever since I have been getting in and starting straight up.
GingerViking is offline  
Status: Playing Half Life 2
AO Member
Joski's Avatar
Join Date: Apr 2006
Location: Bolton, Lancashire
Posts: 118
It could be the clock in the centre console. I thought the same thing until closer inspection and syringing my ears
Alfa's have a strange way of making sound travel behind the dash.
Joski is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

noise , speedo , ticking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome