156 selespeed accelerator problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Cry Like A Baby 156 selespeed accelerator problem

I have a 2000 year 156 selespeed sportwagon,when driving at a steady speed the accelerator is like an on off switch there is no in between,ie if you release the throttle slowly bang the power is gone,and if you press it down slowly bang the powers back on,if you try to accelerate slowly in neutral it,s impossible to hold the engine revs at 2500 rpm,it either falls to 1500 or revs up to 3000+,i have changed air mass meter,throttle body,checked accelerator potentionmeter with the examiner,done the 90 sec on 90 sec off 90 on,after cleaning the throttle body all no good,still the same,anyone got any ideas or had the same problem,thanks it,s fine under acceleration or deceleration its only if you try to maintain a steady speed.
Sponsored Links
Status: asleep
AO Member
Join Date: Oct 2007
Location: United Kingdom
County: Flintshire
Posts: 21
it may not be your potentiometer , i have had a throttle problem recently but fixed it by firstly removing the glove box , then trace the cable from the 'pot' , behind the heater/blower unit and to the left of the airbag container to a white connector . Check this connector out , i did , unplugged it , sprayed plug and socket with wd40 , taped it up and that was the end of the throttle problem . give it a go . it might work .
stevegreen is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , accelerator , problem , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome