147 1.6 Lack of power slight juddering help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-06-09 Thread Starter
Status: -
AO Member
Meaner25's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Cambridgeshire
Posts: 102
Images: 8
147 1.6 Lack of power slight juddering help


My first alfa never driven a 147 before but it seems to have lack of power all the way through the gear range ! It also judders at low revs every so often it nearly died completely pulling off in second gear .

I have changed the air filter to a k&n but replacing the standerd seems to have the same faults !

The power delivery seems constant the the drive but for 120bhp it just seems abit guttless like im thrashing it to make it go !

ive hooked up my snap on scanner and no faults have poped up . ive cleaned the thottle body which helped some has said the egr valve could be blocked !

I have ordered a new Maf sensor as some people said it dosnt always show up on diagnostics

any help or ideas would much apreciated

Many thanks Carman
Meaner25 is offline  
Sponsored Links
Status: Broken again...
Club Member
Membro Premio
GhostyDog's Avatar
Club Member Number: 17
Join Date: Sep 2005
Location: Right Side O The Pennines
County: West Yorkshire
Posts: 25,663
Images: 6
It's a 1.6 in a relatively heavy car, it doesn't come on cam until around 3000RPM and then you have to rag it to the redline to get it to really perform.

A remap will resolve the sub 3000 lag you have and flatten out the delivery
GhostyDog is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , juddering , lack , power , slight

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome