moisture in sparkplugs and coils driving me mad! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-05-09 Thread Starter
Status: -
Join Date: May 2009
Location: Ireland
County: Dublin
Posts: 1

Member car:

***** gt

moisture in sparkplugs and coils driving me mad!

I have an a gt 2.0 petrol engine and I love it to bits but I have had a problem with moisture building up around the plugs(or so i'm told) which is causing the car to lose power when accelerating resulting in motor control system failure symbol appearing on the dash.After cleaning the car performs well for a few weeks then the problem arises again getting worse to the extent that it is nearly undriveable.What can I do??if the coils were replaced would it fix the problem(apparently rust is beginning to appear on the coils)please help me if you have come across this before as its driving me mad
messy1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

coils , driving , mad , moisture , sparkplugs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome