Question About Fault Codes - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 21-05-09 Thread Starter
Status: -
AO Member
Join Date: Sep 2007
Posts: 13
Question About Fault Codes

Hello all,

Second question for the day, so far, regarding fault codes.

If a fault code appears because of a part being faulty, and that part is replace/fixed. Does the fault code that's stored on the ECU system automatically get's removed? Or do they still need to be removed manually (by means of Alfa Diag, Examiner or other Bosch diag systems etc).


Bensmith is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Re: Question About Fault Codes

Some will resolve themselves, others will need the fault-code reset.

Where abouts are you? Someone near you may have AlfaDiag (or even examiner).

If not, most independent garages will have something to reset the light.


iainfm is offline  
Status: -
AO Platinum Member
156Chris's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Surrey
Posts: 12,877
Images: 12
Re: Question About Fault Codes

The fault code will stay "inside" the ECU as a log of all errors that have happened since the log was last cleared ... however as Iainfm has stated for some faults the ECU will continue to operate as if the fault is still present until it is cleared, some will clear themselves ...
156Chris is offline  
(Post Link) post #4 of 4 Old 22-05-09 Thread Starter
Status: -
AO Member
Join Date: Sep 2007
Posts: 13
Re: Question About Fault Codes

Im based in Bath.

Ahhh I thought as much, if the ECU logs errors and holds that log until it's reset.

If there's anyone near me (Bath/Bristol) with AlfaDiag "Can i borrow your time?!" If not no worries, I'll nip down to my local garage.

Cheers chaps
Bensmith is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

codes , fault , question

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome