Frozen my Jets off! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 30-12-03 Thread Starter
Status: -
Club Member
Membro Medio
PR's Avatar
Club Member Number: 51
Join Date: Feb 2003
Location: Middlesbrough, UK
Posts: 7,123
Frozen my Jets off!

Is it me or are Alfas particularly prone to the washer jets freezing up.
This morning was quite cold admittedly, but when I got to work the temp read -1, the engine was upto normal temp, and they were still frozen.
Also, the GF's 147 jets were still frozen when she got to work 50miles and 1 hours drive away!
Both have plenty of washer/antifreeze stuff in them.
Do everyone elses do this or havent I put enough "blue stuff" in?
PR is online now  
Sponsored Links
Status: -
AO Member
Join Date: Nov 2003
Location: sweden
Posts: 52
-8 here today and no problems with the jets, so more of the blue stuff is probably your solution?
147-Jonas is offline  
Status: -
AO Silver Member
jomor's Avatar
Join Date: Apr 2002
Location: Hellas
Posts: 5,237

Member car:

147 1.6lt

"blue stuff" is not enough. you have to spray a lot after filling it with the blue liquid, so the mixture reaches the jets
jomor is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

frozen , jets

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome