bonnet release not working :-( - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 09-05-09 Thread Starter
Status: -
Join Date: Oct 2008
Location: United Kingdom
County: Oxfordshire
Posts: 2

Member car:

156 sportwagon

bonnet release not working :-(

I can't get under the bonnet of my mk1 sportwagen... when I pull the bonnet release it clcik and the bonnet pops a little but not enough to release it fully....

any ideas how I can in??

bullish is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,994
Re: bonnet release not working :-(

Your secondary catch has seized from lack of maintenance.

Search on here for bonnet catch.
You will find it comes up a lot!!

David C is offline  
Status: -
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646
Re: bonnet release not working :-(

thro the grill spray in a lot of WD40 onto the safety lever.

if that fails oyu can open 3 10mm nut, visible thro the grill, 2 at the top & 1 at the bottom, they make the shape of a V.

once these are open you came pull the frame forwards & then you have abit more acccess to the mechanics... the bonnet will lift appox 5" before the cable stops it form rising more

i know this coz I spent 30 min;s last night doing the EXACT same thing as oyu'll need to do.
SEARs is offline  
Status: bought a 75 3.0
AO Silver Member
155 Lounge Winner 09
shiny_car's Avatar
Join Date: Dec 2006
Location: Australia
County: Victoria
Posts: 7,669
Images: 39

Member car:

GT . 155 . 75

Re: bonnet release not working :-(

also try a 2-person approach. fully close the bonnet (so it locks). then have one person firmly push DOWN on the front edge; this will take a bit of pressure off the lock catching spring mech; other person then pull the lever. with the lever pulled, the person holding the bonnet should let go, and see if it springs up properly. if not, try jiggling the bonnet with the lever pulled.

shiny_car is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bonnet , release , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome