Oh Sh*t - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Oh Sh*t

When I set off for work today my 98 156 2.5 V6 was 'spluttering' badly like it wasn't firing on all cylinders or something. It's never done this before but it was so bad I turned back and left it at home. This morning was a particularly damp and miserable one where I live so I'm hoping WD40 on the plugs etc. will sort it out but suspect it's something more sinister....any thoughts ?
Sponsored Links
Status: Now driving a BMW :(
AO Platinum Member
RicksAlfas's Avatar
Join Date: Sep 2002
Location: West Yorkshire
Posts: 17,033
Images: 11

Member car:

1750GTV 147Lusso

Sounds like it could be just damp, or maybe plug leads on the way out.
Had you been through a lot of water yesterday?

Does the V6 suffer from water in the plug holes??
RicksAlfas is offline  
Status: Always hopeful yet discontent.
Club Member
Membro Premio
Ant's Avatar
Club Member Number: 92
Join Date: Jun 2002
Location: Somewhere far beyond...
Posts: 38,299

Member car:

2014 Honda CR-V

Could be the airflow sensor. Happened to me twice, the car was going anything but smoothly then. eek!
Ant is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,995
A common problem with the TS engines is one of the Coil Packs starting to fail.
The V6 uses the same type of system (individual coil for each plug) the symptoms are the same as a plug or plug lead failing.
David C is offline  
Status: - Update
Posts: n/a
Liberal spraying of WD40 seems to have fixed it but it's nothing like as damp in the air today so the jury's still out. Thanks for the responses.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome