147 Cloverleaf wheel noise! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 04-05-09 Thread Starter
Status: that time again
AO Platinum Member
Guili's Avatar
Join Date: Aug 2008
Location: South Africa
County: Mpumalanga
Posts: 13,687
Images: 7
147 Cloverleaf wheel noise!

Hi all,

yes...I know, you don't get a 147 Cloverleaf...I slapped cloverleaf stickers on mine so now its a 147 Cloverleaf!!!

Anyway, last week before installing the 35mm H&R springs I heard a noise from the left rear wheel...the noise increases when the speed increases and vice versa!

Its like something is on the tire...I looked and inspected it but to no avail...I hope it's not a wheel bearing. Its not a whining or loud noise, just a noise!...lol hard to try and explain a sound!

Maybe its the brake disc or pad on the left rear wheel?

any suggestions will be appreciated...

Oh, when we replaced the springs, we found the rear torshion bar connected to the left rear, that rubber was a bit loose....could this be it????

Guili is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , cloverleaf , noise , wheel

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome